GM Truck Club Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
I bought a 2003 Suburban last yesr and have just recently fixed the non-functioning rear wiper. In my case, there were 2 separate problems that needed to be fixed.

The ground wire contact had corroded at the terminal block where the rear hatch wires enter the body - at the roof line just inside the rear hatch. The boot comes off with a little effort, and there are a couple of clips to compress to release the terminal block. After fixing the ground wire, I still did not have a functioning rear wiper, although I had power to the motor.

I ordered a new (reman) wiper motor from an internet supplier and installed it this week, and voila! - a rear wiper that works.

Along the way I accumulated a couple of pre-2003 wiper motors. If someobody needs one, let me know. They are REALLY CHEAP - as in $10 plus shipping.

Neil
 

·
Registered
Joined
·
7,979 Posts
Very common problem with GM suvs blazers includded. thanks for the tips.
 

·
Registered
Joined
·
11 Posts
I have an 2004 that the dealer is saying I need a new rear wiper control module for. I have a couple questions maybe you can help me with.

1) Is the control module part of the motor? I can't find a control module anywhere, only wiper motors.
2) All the wiper motors I'm finding say they are for sale without the washer pump. Is that something I should be concerned about? Will I be able to salvage the existing water pump when I replace the motor?
 
1 - 3 of 3 Posts
Top