GM Truck Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,667 Posts
Discussion Starter #1 (Edited)
Anyone out there know how to remove this windshield washer reservoir?I can see 2 screws that are holding it in place, but I can tell there are more.None of the ones underneath-the wheel well-look exactly right, but I'm betting it is one of them.
I sure don't think that I have to take the whole wheel well out-exerything on the driver's side of the engine compartmant is bolted to it.
Help,
Charlie
PS-It is leaking like a sieve.
 

·
Registered
Joined
·
4,151 Posts
The reservoir was leaking badly on my wife's 2001 suburban and I had to remove the battery and battery tray to reach the top bolts and then crawl underneath to reach one or two bolts from below. It turned out both pumps were corroded and leaking. I had to replace both pumps.
 

·
Registered
Joined
·
1,667 Posts
Discussion Starter #3
Darcy,
Thanks for the tip.I'm heading under it now.There are two screws in plain sight-on top-.It is under the 2nd battery "platform" which I took off already-no second battery.I can't really tell which are the correct screws/bolts to take off underneath,so I'll just take them off until I get lucky.
I'm short of $$,so I'm hoping just the plastic is split,and can be glued in some way.
It is a 1998 with 198,700 miles-owned for 3000 miles and 10 months by me-so it was due to have some breakage/failures.I replaced the brake booster-$130 with tax after I got my core charge back-last week.
Thanks,
Charlie
 

·
Registered
Joined
·
4,151 Posts
Charlie, I think I remeber peeling back part if the rubber or plastic inner fender skirt to expose the bolts or screws. I think the whole until comes out from the bottom anyways but be careful not to break the plastice hoses or lines running to the pumps as they are very expensive to replace (i know).
 

·
Registered
Joined
·
1,667 Posts
Discussion Starter #5
Thanks for the help.I got it out.It was 2 screws, but once I had them out it still didn't just come out.It was hanging up on something else-I think on a protruding screw.
I found a split along a seam,and it was leaking at the grommet where the pump pushes in.I don't think I'll really be able to completely seal the leak by the grommet.I'm pretty sure I did seal the split seam.
I just reinstalled it.I'll wait a day or two and see how long it holds water.If it holds 'some' water for 2 days or so ,it will be OK for the trip we will take to AZ-from New Orleans-this summer.
On trips I need to be able to clean the windshield.Around town,I can just clean it by hand.
I wish I had the spare $60-I would buy a new one.
Thanks,
Charlie
 
1 - 5 of 5 Posts
Top