GM Truck Club Forum banner

61 - 80 of 104 Posts

·
Registered
Joined
·
11 Posts
I'm having the same issue. I have a 2007 Chevy Silverado I had the motor rebuilt and 2015 because I lost compression on the number 7 cylinder. Now I'm having the same issue with the Stabilitrak light coming on and the rough idle. I spent over $3,000 having the motor rebuilt and now it's rough idling the Stabilitrak lights coming on and I'm here in a little ticking noise. If I have to rebuild this motor again I'm not going to be very happy. GM knows about this issue they need to do something about it. I'm all game for the lawsuit. Does anyone know a lawyer that would be good for this kind of suit?
 

·
Registered
Joined
·
11 Posts
I've searched in other forums and this seems to be a common problem with a lot of people. If GM has known about this issue and hasn't done anything about it then something needs to be done. I can't afford 3000 dollars every few years having my motor rebuilt and I'm sure other people feel the same way
 

·
Registered
Joined
·
1 Posts
I need people to get in on this if it's going to work. Do u know the earliest year model that this problem had started?
I’m in! 2009 Suburban. Let me know. I just rebuilt the top end of my engine without success. Sad that I haven’t found a good fix on this forum yet but this could help with the large paperweight in my garage.
 

·
Registered
Joined
·
14,764 Posts
I need people to get in on this if it's going to work. Do u know the earliest year model that this problem had started?
For the fullsize trucks, I think these engines were used in 2007
However the Trailblazers and Envoy trucks had them in 2005, maybe earlier.

They were also used in cars, any that used the LS engine family
 

·
Registered
Joined
·
1 Posts
I have had 3 tahoes 2009-2010 and all had this same issue. My wife has a '07 6.0 suburban and it too has this issue. so 4 out of 4 that i owned had the same problem. It is time for a lawsuit!!!
 

·
Registered
Joined
·
14,764 Posts
So guys, two different issues here.

This thread started life as a problem with system shutting down and low power mode being activated.

This is not an AFM thread.

In my opinion, GM stepped up to the issue with the motor/sensor on the throttle body.

They fix it and they then provide a 10 yr warranty on the new parts.

This is all for free, no cost, no lawsuit, as I see it; at least, not one you could win.

The AFM problem, total engine failure, that's a big one, GM is ignoring it, hoping it will go away.

Why, because it's big bucks.

This is where the lawsuit needs to take place. All of you who have had to pay out of pocket to have an engine rebuilt need to get on this lawsuit.
 

·
Registered
Joined
·
11 Posts
I'm not worried about how the thread got started. People who are having issues with the stabilatrac and the rough idling is what I'm worried about. I'm trying to get anyone and everyone that has had or is having this issue. Something has to be done. Like you said, GM is hoping this issue is just gonna go away but it's not. Not until the consumers put enough pressure on them to force them to do something. The more people on board the better off we'll be. So ANYONE that's having issues with the stabilatrac light and rough idling please get in touch with me so we can get this thing going
 

·
Registered
Joined
·
14,764 Posts
Chris, the point I'm making, is the catastrophic engine failure, due, we believe to failure of the AFM lifters, is where GM is letting their customers suffer. The big money (for the lawyers) is in the engine failures.
 

·
Registered
Joined
·
1 Posts
Im having the same problems, 2008 SUBURBAN 130k miles , misfire #3 stab trac and engine light on... and after reading this thread im like ugh... changed plugs and wires, next will be injectors...
 

·
Registered
Joined
·
14,764 Posts
Im having the same problems, 2008 SUBURBAN 130k miles , misfire #3 stab trac and engine light on... and after reading this thread im like ugh... changed plugs and wires, next will be injectors...
"Engine light on"..........what are the codes?

Injectors could cause #3 mis-fire; but not the other messages. Change the motor on the throttle body ($30)
 

·
Registered
Joined
·
11 Posts
Chris, the point I'm making, is the catastrophic engine failure, due, we believe to failure of the AFM lifters, is where GM is letting their customers suffer. The big money (for the lawyers) is in the engine failures.
Is that what causes the stabilatrac light to come on and idle rough?
 

·
Registered
Joined
·
14,764 Posts
A good possibility, but the engine codes would tell us for sure.
 

·
Registered
Joined
·
11 Posts
It doesn't read unless the light is on. Mine usually goes off when I cut the truck off and restart it. And usually it only does it when it's really cold. It hasn't came on in a few weeks because it hasn't been that cold here
 

·
Registered
Joined
·
4 Posts
Hey all, I am reading thru this thread, getting an ever growing pit in my stomach. My 07 suburban started acting up on me a couple of weeks ago. Rough Idle, the service stabilitrack/service traction control lights came on. I limped it home, rough shifting from 1st to 2nd. So far I have replaced the plugs, coils, and fuel injectors on the pass side. Now my oil pressure sending unit is acting up. So that and the injectors on the drivers side are next, but Im not liking what I am reading as far as engine rebuild. This is the firs time it has acted up like this in the 6 years I have owned it.

So is it a waste of time replacing 02 sensors too? I am doing everything I have researched, I cant afford a rebuild.
 
61 - 80 of 104 Posts
Top