GM Truck Club Forum banner

81 - 100 of 104 Posts

·
Registered
Joined
·
306 Posts
Hey Ray, the link didn’t work? I remember that thread though. Good reference.

James K... pull the codes. History too. Post what you find on this thread. But, you have all the symptoms... some got lucky and only had to rebuild the top end once. Others, not so much.
 

·
Registered
Joined
·
4 Posts
Hey Ray, the link didn’t work? I remember that thread though. Good reference.

James K... pull the codes. History too. Post what you find on this thread. But, you have all the symptoms... some got lucky and only had to rebuild the top end once. Others, not so much.
I have pulled the codes, I will have to do it again, I don't remember what they are at the moment. I have o0ther issues going on as well. My oil pressure sending unit went bad and my evaporative system is throwing a code as well. I will post them once I get them again.
 

·
Registered
Joined
·
4 Posts
I'm not worried about how the thread got started. People who are having issues with the stabilatrac and the rough idling is what I'm worried about. I'm trying to get anyone and everyone that has had or is having this issue. Something has to be done. Like you said, GM is hoping this issue is just gonna go away but it's not. Not until the consumers put enough pressure on them to force them to do something. The more people on board the better off we'll be. So ANYONE that's having issues with the stabilatrac light and rough idling please get in touch with me so we can get this thing going
Have you guys found out any info on this my 07 Tahoe has just started doing this. Not really liking what I’m reading as I don’t have 4-7 grand for a new engine. Feel like I just got kicked in balls.
 

·
Registered
Joined
·
4 Posts
Have you guys found out any info on this my 07 Tahoe has just started doing this. Not really liking what I’m reading as I don’t have 4-7 grand for a new engine. Feel like I just got kicked in balls.

Try and clean the throttle body. The first time I got the messages that fixed it. If it does fix the problem I would look to sell your Tahoe.
 

·
Registered
Joined
·
4 Posts
Have you guys found out any info on this my 07 Tahoe has just started doing this. Not really liking what I’m reading as I don’t have 4-7 grand for a new engine. Feel like I just got kicked in balls.

I am tearing into mine this coming weekend. I am replacing all the AFM lifters. I cant afford 3-7 grand either, the set I found on Partsgeek was 300 for all the lifters, gaskets, head bolts and lifter trays. If it works I may end up selling it.
 

·
Super Moderator
Joined
·
773 Posts
Without the cods you or us are only guessing, it could be anything from $25 and 20 minutes of your time to a new engine. There is more than one thing that can cause these issues. Please help us help you, go to an auto parts place fore a free code check. If you went ot a mechanic to get the codes read, if you paid for it insist that they tell you the codes that they read.
 

·
Registered
Joined
·
14,764 Posts
If your having a traction control off and stability control off and reduced power message, IT IS NOT AN AFM LIFTER PROBLEM.

It is only a $30 fix

You need to change the pedal position sensor on the throttle body.

Please read the thread to see if your problem matches the problem outlined in the GM service bulletin
 

·
Registered
Joined
·
4 Posts
Sorry the code that popped up is a cylinder 2 misfire.. it only happens when when im letting it warm up in the morning before work.The traction control light will pop on as well. The check engine light will flash until I start driving it. Once driving the traction control off light will go off and the check engine light will quit flashing. I don’t get the message about reduce engine power nor has it stalled on me yet.
If your having a traction control off and stability control off and reduced power message, IT IS NOT AN AFM LIFTER PROBLEM.

It is only a $30 fix

You need to change the pedal position sensor on the throttle body.

Please read the thread to see if your problem matches the problem outlined in the GM service bulletin
haveing
 

·
Registered
Joined
·
14,764 Posts
OK, that is a different problem.

It is also different that the AFM problem.
AFM is only on cylinders 1, 4, 6 and 7.

I would start a new thread, detailing to your problem; and, I'm sure we can get it solved.
 

·
Registered
Joined
·
11 Posts
I haven't had any luck finding a lawyer to take the case. Apparently someone has to die before any action will be taken. So if anyone who wants to try and get this going maybe y'all can help try and find someone to take the case. I've had 75 people email me about this but I know there's a lot more having the same issues. Maybe if we all start harassing GM or some of these lawyers we can get something going . I'm not giving up yet but any help from u guys would be great. Feel free to email me with any questions
 

·
Registered
Joined
·
1 Posts
I’m new to the forum, however I had the same issue originally posted. I have an 07 Tahoe LTZ with 193k. Was stopped at a red light, the truck stalled, started it back up, and the SE light came on with the Service Stabilitrack and Service Traction Control warnings. I had no AC, no tach, rough idle, shifting hard between 1st and 2nd, and it didn’t start on first turn. Got it home and had the codes read. It gave a faulty crankshaft position sensor code. Bought a new one and installed and it seems to have fixed the issue.
 

·
Registered
Joined
·
3 Posts
I'm not worried about how the thread got started. People who are having issues with the stabilatrac and the rough idling is what I'm worried about. I'm trying to get anyone and everyone that has had or is having this issue. Something has to be done. Like you said, GM is hoping this issue is just gonna go away but it's not. Not until the consumers put enough pressure on them to force them to do something. The more people on board the better off we'll be. So ANYONE that's having issues with the stabilatrac light and rough idling please get in touch with me so we can get this thing going
I am having same problem. 168 thousand miles
 

·
Registered
Joined
·
3 Posts
I’m new to the forum, however I had the same issue originally posted. I have an 07 Tahoe LTZ with 193k. Was stopped at a red light, the truck stalled, started it back up, and the SE light came on with the Service Stabilitrack and Service Traction Control warnings. I had no AC, no tach, rough idle, shifting hard between 1st and 2nd, and it didn’t start on first turn. Got it home and had the codes read. It gave a faulty crankshaft position sensor code. Bought a new one and installed and it seems to have fixed the issue.
I hope that is what's going on with mine. No other problems at all. Just all of a sudden popped up
 

·
Registered
Joined
·
14,764 Posts
Read the codes, that will show you the direction to take
 

·
Registered
Joined
·
1 Posts
Mobill,

Hey there! As a customer service representative, I'm not able to provide much in the way of do-it-yourself information, so I'm glad to see forum members are beginning to step in with feedback. If you have any lingering concerns please contact me via private message.

Jennifer T.
GM Customer Care
Hellow my name is Matthew Amandola. I have a 2008 chevy avalanche and have the same problems sadly as many on this forum and others. I have seen people say there is a extended warranty and or gm is stepping in and paying for some or all of the repairs for these problems i have the stabiltrack/ traction control codes along with the rough idle and bad shifting from 1st to 2nd gear. The code im getting is a misfire on cylinder 6. Ive changed the spark plugs and switched engine packs so far with no resolution to the problem. Reading these forums makes me hesitant to just keep trying different fixes to see if they resolve the problem because it could be 1 of maybe 10 different things. Im wondering my next steps and if there is any info or help you could give me it would be much appreciated. I live in middletown delaware. My vin is 3GNEC12068G292784. My email is [email protected]. Again any help is much appreciated thankyou
 

·
Registered
Joined
·
3 Posts
So I’m having the same problem all the sudden my stable track came on my check engine light started flashing and I was getting a cylinder six misfire code. Being semi-educated I pulled all the plugs for every cylinder check them all six and seven or slightly fouled pulled all the wires replaced all the wires because a few of them weren’t reliable as I found when I pulled them off and then decided to change coil packs around and I’m still getting a cylinder six misfire and I’m still getting the stable track light and I’m still getting the flashing check engine light and I’m still getting the number six cylinder code. I have exhausted every option besides taking the top into this motor off and I’m about to take it and run it into a freaking brick wall and collect the gap insurance because I’m about tired of chasing problems with his damn Chevy even though I’ve owned Chevys since 2004 it’s getting old!

Also change the brake switch because that’s a known issue and I had to replace it a few years ago thinking that was what was causing the stable track issues so that’s another thing ruled out.....
 

·
Registered
Joined
·
14,764 Posts
Well, we'd love to help you; but like taking your pet to the vet, patient information is helpful.
 
81 - 100 of 104 Posts
Top