GM Truck Club Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
151 Posts
Discussion Starter · #1 ·
Looking for some opinions. 1984 3/4 ton Scottsdale 5.7L, 4 barrel carb, 4 speed manual, heavy duty cam installed when it was only a couple years old. No catalytic converter (3/4 ton didn't have them that year), around 187,000 miles. Truck did a lot of hauling and towing including a 29 ft camper. Had some electrical issues (fuse link replaced next to the firewall) and brake issues. My dad bought it new in 1983, always smoked a little taken to the dealer several times while under warranty and they could adjust to either white or blue smoke but never completely got rid of it. Only used about 1/2 quart of oil between 3,000 mile oil changes. Truck was my daily driver from 1990 till 2000 then switched off between it and my 1990 Silverado 3500 7.4L. I helped take care of this truck from the day my dad brought it home, I learned to drive in it, and it was my graduation present in 1990. As many on here can probably relate it is still my baby. History lesson over - didn't have time to deal with the electrical and brake issues so the truck sat for about a year and a half. Finally decided it was time to put it back on the road, everything was back in working order but it was running real rich. Several weekends I ran it around the farm figuring with the fresh gas it would clear up then one weekend while it was just idling outside the garage for about 10 minutes it just stopped. Oil level was full and oil pressure was running normal before it quit. When it stopped I was standing within 20 feet of the truck and didn't hear any noises it just sounded like you shut the key off. Now you can't turn the motor by hand and it very slowly turns over with the starter and doesn't attempt to fire (the plugs are sparking).

Now for the opinions - should I have the motor pulled and opened up to see what happened and if feasible to fix it or just go straight for a new motor? Haven't done any research yet so I have no idea how expensive either option would be. Any opinions/suggestions would be appreciated.

Land vehicle Vehicle Car Pickup truck Truck
 

Attachments

· Registered
Joined
·
151 Posts
Discussion Starter · #8 ·
Well, the truck is fixed but now I am broke. GM performance engine 5.7L 290 hp, fly wheel, harmonic balancer, clutch fan, new starter, water pump, fuel pump, master cylinder, wheel cylinders, brake pads, calipers, emergency brake cable, all hoses, the list goes on and on. Now I have a leak in one of the gas tanks that I need to find and determine if patchable. Carburetor still needs some fine tuning after I run out the current tank of gas which is a mixture of old and fresh gas. Engine Auto part Vehicle Motor vehicle Fuel line
 

Attachments

· Registered
Joined
·
151 Posts
Discussion Starter · #12 ·
Looks good
Great it is running again-probably better-much better and stronger-than new
Weren't the 350's just 160-170 hp back in 1986?
1984 - pretty sure the original engine was 165 hp. Feels stronger on take off and on level ground she will cruise at 65 mph barely touching the throttle. Haven't had much time to play with it yet. Seems my shift point from 3rd to 4th is higher now but then again it has been awhile since I had her on a highway so it could just be my imagination. Never had a tachometer in it - maybe a future project if I find one that looks good/fits well in the dash somewhere. Anxious to get through a couple tanks of gas and have the carburetor fine tuned to really find out how she is going to run.
 

· Registered
Joined
·
151 Posts
Discussion Starter · #15 ·
Yea it just gained about a 100 ponies over factory, besides better throttle response you might notice better fuel mileage.
The downside is all these extra ponies in front of an OEM trans can spell trouble.
I suspect you dont hotrod the truck, but just be ware the trans has some miles on it and may act out for attention in the future.
No hotrodding but we all have to spin the tires a little every once in a while. Plan to baby her in hopes she will keep going for a long, long time. Maybe some occasional light towing - I will let the 08 Duramax handle the heavy stuff.

- - - Updated - - -

I was hoping you weren't going to mention that. BY the time I got my 1990 305 running right, my front clutch pack locked up on me. Well I was planning on a complete overhaul sooner or later. Runs fantastic now !
I had a new clutch installed between 10,000 and 20,000 miles ago. By being a 4 speed manual hoping the transmission doesn't give me any trouble. Guess time will tell.
 

· Registered
Joined
·
151 Posts
Discussion Starter · #16 ·
Quick question - oil pressure gauge quit working soon after the new engine went in so I immediately added a new gauge and a tach. Oil pressure ran at 75 after installing the new gauge so figured that is why the factory gauge that only went to 60 quit working. Took the truck for inspection this evening and stopped at a store on the way home. When I started it back up oil pressure went to 100. Backed out of the parking spot and it went down to 75. Stayed at 75 all the way home. Parked in my driveway and at idle pressure went back to 100 give it a little throttle and it goes back down to 75. Dark already so I didn't try to double check the wiring (both original and new gauge are electrical). Changed oil and filter around 400 miles ago. Any suggestions?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top