GM Truck Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys I am having problems with my 1994 GMC Sierra. It just cut off going down the road the other day and wouldn't crank back. The starter just wouldn't turn it over. I changed the starter and it was sluggish but cranked up and ran but it would choke down and quit when I turned the wheels all the way one way. I drove a short distance 100 yards and turned around and came back and now it doesn't seem to want to start is smoking a little worse than usual and smoking from a vacuum in front of throttle body and out of hose out of valve cover.
What is the reason?
How can I correct this

Sent from my moto e6 (XT2005DL) using Tapatalk
 

·
Registered
Joined
·
15,488 Posts
Doesn't sound too good.
I think I'd do a compression check
I'd remove the belts and pull all of the plugs before the compression test
That will let it spin a lot easier
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I agree it doesn't.
Got hot maybe?
Freeze plug above starter leaking...

Sent from my moto e6 (XT2005DL) using Tapatalk
 

·
Registered
2004 Silverado 1500 4WD Crew cab 5.3L
Joined
·
23 Posts
Hey guys I am having problems with my 1994 GMC Sierra. It just cut off going down the road the other day and wouldn't crank back. The starter just wouldn't turn it over. I changed the starter and it was sluggish but cranked up and ran but it would choke down and quit when I turned the wheels all the way one way. I drove a short distance 100 yards and turned around and came back and now it doesn't seem to want to start is smoking a little worse than usual and smoking from a vacuum in front of throttle body and out of hose out of valve cover.
What is the reason?
How can I correct this

Sent from my moto e6 (XT2005DL) using Tapatalk
Cut open your oil filter, cut out some pleats, squeeze the pleats in a vise to squeeze out the oil, look for shiny stuff. This is a good way to look at what's going on inside the engine. Magnetic particles equals crank, non magnetic probably bearings.
 
  • Like
Reactions: ww371

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
How about this guys.
Vacuum from throttle body to pcv valve missing,
Vacuum from throttle body (rear) to egr missing.
Anyone think this will correct it by replacing hoses?

Sent from my moto e6 (XT2005DL) using Tapatalk
 
1 - 7 of 7 Posts
Top