GM Truck Club Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys! I've searched high and low on the net and can't seem to find any concrete answers to my questions and I'm getting very tired of my lack of working speedometer. I have a 93 suburban 1500 4wd. It's got about 172 on the odometer, but I rebuilt the engine about 25k ago, and transmission about 1400 miles ago. It's had some electrical quirks since the day I bought it (used about 2 yrs ago). For example, the turn signal makes the volt gauge jump up and down with each blink, and if you turn on the left blinker while doing over 60mph (I say that because the speedo is maxed out as of about 50mph actual speed) it will cause the needle on the speedo to jump back to around 50mph or so, then resumes being maxed out. UNLESS you leave it on for more than 10 seconds then it will do it again. The speedo will slightly jump up and down when moving slowly, about 5 mph, but it starts out about 15 mph over the actual speed of the truck. Once you hit about 35 mph it moves up to about 20-25 mph over actual speed. By the time you hit about 50 mph it's maxed out over 80mph on the dash. I've verified the vss is reading correctly with a scan tool. I'm leaning towards the drac, but I cannot be sure the one that's in it is even original to the truck, as it previously had some modifications I believe (lift, brush guard, etc that have been removed). My code is qxl if that helps. I need someone to give me a DEFINITIVE answer on how to test the drac, or at the very least how to guarantee what's wrong with my speedo. I live paycheck to paycheck and after forking out a grand to rebuild my trans with premium parts, I'm way behind on bills and cannot afford to spend even $40 on something that will not for sure fix it. Thanks in advance!
 

·
Registered
Joined
·
5,200 Posts
If you want a DEFINITIVE answer be a good boy and tell us what kind of truck and it's details.

We get so tired of asking for truck info to the point of some members not responding to mystery truck questions.

Ted
 

·
Registered
Joined
·
16,657 Posts
Help me understand what you want to do?
What's a DRAC?

And QXL, I'm not familiar with that RPO code
 

·
Registered
Joined
·
4,222 Posts
Ahhh... drac modules.... here's a link with some info... it is essentially the vss... used on 89-95 tbi's... i just remembered reading about them before when changing tire size/gear ratio.... they are what calibrates the "computer" to the correct speed. Other than that i dont know anything about them...

Al

http://uniquediesel.com/drac/
 

·
Registered
Many... All Gm
Joined
·
704 Posts
Hey, bud...sorry for the late response here...I have a funeral, I'm taking care of. Basically this is a pita to actually diag...here is some info for you but, generally... If vss is sending good SIG to buffer...or if its cable, gear and cable are good, not sticky broke ect, you have two options. The cluster...which sounds like yours doesn't have resister in it yet...or the buffer...I keep, known good parts...but that's not a luxury for everyone...that said, I hosted some info for you...I have more but am short on time...this is bullet points, read carefully can be extremely informative (and yes...your drac is probably the wrong one anyway, or modified) please don't host these.. Download them...as I'll take the link down shortly...as I haven't had time to "edit"...https://drive.google.com/folderview?id=1vEBkVyEzLQNxLBaYne5wG1vNH4R3k656
 
  • Like
Reactions: thegawd and RayVoy

·
Registered
Joined
·
5,200 Posts
Thanks Al I don't know how I missed his vehicle but I did.

A member here was modifying and selling those a few years ago. I think maybe @Crawdaddy? Or maybe he had a couple of spares. Whoever it was kept a lookout anytime he was at a wrecking yard and got all he found.

I think a speedometer calibration outfit (if there's any left) can supply a calibration module that will replace the drac.

Ted
 
  • Like
Reactions: thegawd

·
Registered
Many... All Gm
Joined
·
704 Posts
Hey @Triggermike1986 sorry, I just saw last night, the permissions were off for this...I hope this is still a help to you, and am very sorry to have left you hanging.... Second thought, hopefully you have this figured already, and its useless to you...but just in case.

Thanks @xPosTech for finding this :D
 
1 - 12 of 12 Posts
Top