GM Truck Club Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi everyone i have a texas edition Chevy Silverado 1500 year 2009 and one of my turn signals flashes quickly when i signal left it starts to flash fast any one know why that happens?... could it be a fuse ?... i checked all the lights when i put the signal and all of them work so i dont know why it does that sometimes it flashes normal other times it flashes super fast.
 

·
Registered
Joined
·
14,498 Posts
Hmmmmm, my "09 started doing that yesterday, same side. In my case it is a bulb, yours probably is as well

My rear has 2 bulbs on each side, one of the left ones is burnt out.
I'll probably change it later today.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Hmmmmm, my "09 started doing that yesterday, same side. In my case it is a bulb, yours probably is as well

My rear has 2 bulbs on each side, one of the left ones is burnt out.
I'll probably change it later today.
 

·
Registered
Joined
·
14,498 Posts
If the right side works, just compare each side.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
When i checked it the 2 front bulbs did work so did the back one but you say it has 2 bulbs on the rear i might forgotten to check the second bulb does your truck have plastic door handles? Just asking becuase mine does and they break so easily i found some at 1auto.com but havent ordered them yet some durable ones.
 

·
Registered
Joined
·
14,498 Posts
Gman, I didn't say your truck has 2 bulbs on each side in the rear, I said mine does. Mine is an Avalanche and yours is the Silverado, the rear configs could be different.
But you should check for a burnt out bulb.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Gman, I didn't say your truck has 2 bulbs on each side in the rear, I said mine does. Mine is an Avalanche and yours is the Silverado, the rear configs could be different.
But you should check for a burnt out bulb.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Lol ok because you said "my truck started to do that to" so i thought you had the same truck like mine you didnt mentioned you had an avalanch
 

·
Registered
Joined
·
182 Posts
The 09 Silverado has TWO rear bulbs per side. One is probably burnt out.
 
  • Like
Reactions: RayVoy

·
Registered
Joined
·
42 Posts
It may be the flasher unit. I had a similar condition with my 94 K1500. I replaced the flasher and all is fine.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
Where is the flasher unit located? On your car ill check it out thanks for your advice i checked all the lights and they work perfectly fine but the signal just goes super fast
 

·
Registered
Joined
·
14,498 Posts
Gman, I don't beleve you one, the body control unit takes care of the flashing.

What about the bulbs at the rear?
Do you have one, or two, per side?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
Gman, I don't beleve you one, the body control unit takes care of the flashing.

What about the bulbs at the rear?
Do you have one, or two, per side?
Ill have to double check but i think it has 2 bulbs
 
1 - 20 of 24 Posts
Top