GM Truck Club Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
All,
I have an 85 4x4 Suburban. 3/4T AT V8. I bought it after it sat for a coupla years. While driving it home. (Tx-Tn) It started leaking txmsn fluid pretty bad. Seems to be coming out of the top somewhere. Anyone dealt with this? Could some mud daubers have plugged a vent or something? Dried out gasket maybe? Any ideas will be appreciated. Thanks!
K
 

·
Administrator
Joined
·
4,886 Posts
RE: Txmsn Oil Leak.

How long did it sit? Could be a few things I think I'd check the gaskets first, etc.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks, Steve.
Yea, it was about two years. It was run up fairly regular and runs like a champ 'cept for the leak. Its a really great truck. Thanks. I am lookin it over.
K
 

·
Premium Member
Joined
·
1,625 Posts
I have an 86 Burb that if I don’t drive it daily will leak trany fluid out of the seals I think.

Never could figure out why but once you Keep driving it on a regular basis it stops leaking.

So I’m just guessing here but I bet the pan seals are drying out, or maybe a seal a little higher.
 

·
Registered
Joined
·
2,428 Posts
I couldn't see a vent on my 700R4, but usually a/t have a vent near the top. If you have fluid coming from the vent, it could just be overfilled, or the valve body could be gummed up and boosting pressures abnormally.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top