GM Truck Club Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Black Pearl is the name of my ride. It's a '99 Chevy Suburban K2500 that I bought to haul around all of the kids when I remarried. The fact that it's golden brown with black flairs, and the popularity of the Pirate movies in our household is what earned it it's name.

I'm a forty-something white dude and I live in SoCal, Inland Empire. I love taking my truck out to the desert or mountains and engaging the four wheel drive. I don't mind if she gets a little trail rash, but I do try to avoid any dings and dents. I joined this forum in hopes of finding out about off-road excursions and other fun stuff with like-minded people.

I look forward to meeting you guys,

Clutch (my handle from another forum)
 

·
Premium Member
Joined
·
1,101 Posts
Welcome Clutch! How about some pictures of The Pearl? We all like pictures.
 

·
Registered
Joined
·
4,151 Posts
Welcome to the site!
 

·
Registered
Joined
·
2,805 Posts
:sign0016: and as they all said pics please!! I noticed its a 2500 what motor does it have??
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
Thanks guys! It's good to be here.

Pete95Sierra: It's the 7.4 Litre (454) gas... has less than 500 miles on it as a matter of fact, the last one ate a cam lobe. That was $5000 I didn't want to spend.

Pics are on the way. I'm headed to the Barstow desert next week so I'll get some on the trails.

Clutch
 

·
Registered
Joined
·
2,805 Posts
mmmmm big block (drools)...and pics of your wheelin trip are a must!!
 

·
Premium Member
Joined
·
1,101 Posts
Thanks guys! It's good to be here.

Pete95Sierra: It's the 7.4 Litre (454) gas... has less than 500 miles on it as a matter of fact, the last one ate a cam lobe. That was $5000 I didn't want to spend.

Pics are on the way. I'm headed to the Barstow desert next week so I'll get some on the trails.

Clutch
My 78 with the 454 eats cams for a snack. I have probably lost 6 cams in the 20 years I have owned it. I am getting ready to put some small chamber heads on it (as soon as I finish the port work) and I will check the cam when I have it apart. If it is flat, I may go roller. I have also heard of a fix for an oiling problem that causes it, but don't have all of the details on that yet.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
GaryL: thanks for the post... I was thinking I was the only schlep who ever roasted a 454 at 100k. When you find out about the oil fix let me know.

Clutch
 

·
Premium Member
Joined
·
1,101 Posts
I think it has something to do with drilling a small hole in the oil galley plug that is behind the cam timing gear. That is supposed to let the air bubbles out of the oil galley which they say causes the problem. I think one of my neighbors has a big block apart that has this mod on it. If so, I will take some pictures and post them up.
 
1 - 14 of 14 Posts
Top