GM Truck Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hey everyone, I'm posting on behalf of my fathers truck. Just recently his oil pressure gauge pegged at 80 psi. The truck runs fine, no weird noises/smells, so I'm 99% certain it's either the stepper motor or the stock sending unit. Now to fix his problem, I figured I could just buy a mechanical oil pressure gauge and use that, and not worry about replacing the sending unit or fixing the gauge (both are kind of pricey). I called two auto repair shops, and both places said "just replace the sending unit and be done with it." BUT, I don't to replace that, if it's a gauge cluster issue. I would just end up throwing away money. So I'm set on just running a mechanical gauge. Only one question, where would I thread the gauge in at to read oil pressure? Would I thread it in where the stock sending unit is, or is there another area to thread it in so that I can keep the sending unit in?
 

·
Registered
Joined
·
5,836 Posts
Hey everyone, I'm posting on behalf of my fathers truck. Just recently his oil pressure gauge pegged at 80 psi. The truck runs fine, no weird noises/smells, so I'm 99% certain it's either the stepper motor or the stock sending unit. Now to fix his problem, I figured I could just buy a mechanical oil pressure gauge and use that, and not worry about replacing the sending unit or fixing the gauge (both are kind of pricey). I called two auto repair shops, and both places said "just replace the sending unit and be done with it." BUT, I don't to replace that, if it's a gauge cluster issue. I would just end up throwing away money. So I'm set on just running a mechanical gauge. Only one question, where would I thread the gauge in at to read oil pressure? Would I thread it in where the stock sending unit is, or is there another area to thread it in so that I can keep the sending unit in?
if this is a 2003 model the dash indicators has these type issues .

I would get a pressure gauge and see if the pressure is normal anyway.

- - - Updated - - -

if this is a 2003 model the dash indicators has these type issues
I would get a pressure gauge and see if the pressure is normal anyway.

could be the sender/wire etc. measure ohms engine off and engine running.


[/QUOTE]
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
if this is a 2003 model the dash indicators has these type issues .

I would get a pressure gauge and see if the pressure is normal anyway.

- - - Updated - - -

if this is a 2003 model the dash indicators has these type issues
I would get a pressure gauge and see if the pressure is normal anyway.

could be the sender/wire etc. measure ohms engine off and engine running.
[/QUOTE]

It's a 2005. I know it's a known issue. I'm almost positive it's pressure is fine, but should check regardless. But I'm asking where to tee in an oil pressure gauge if I were to get one. Would it replace the sending unit all together, or is there another place to get pressure readings from besides the sending unit?
 

·
Registered
Joined
·
5,836 Posts
measure the resistance as I mentioned to determine if the sender is bad. remove the connector and see what resistance is coming out of the sender engine off/on. then we can determine if it is a sender or even just bad wiring connector at the sender.

you can place a T fitting in the engine oil pipe bore then connect the two parts so you can connect the sender and the oil pressure gauge line. local parts store should have the brass fittings/adapters to complete this.
 
1 - 4 of 4 Posts
Top